Home Addons Support

Old Versions For the risk-takers among us

Read this first

Are you attempting to support 1.7 (and up) players on an older server? ProtocolSupport's old versions are unsupported, and the build for 1.8.8 in particular has quite a few problems. However, a great alternative approach would be to use a setup involving two (three if you're on 1.10.x) other plugins.

  • ViaVersion - allowing 1.9.x players and above to connect
  • ViaRewind - allowing 1.7.x and 1.8.x players to connect
  • ViaBackwards - allowing 1.9.x and above to connect (for servers on 1.10.x and later)

All of these plugins are required for this approach, but this is an entirely supported setup, and bugs are likely to be fixed for all of these plugins. If, however, you really want to stick with ProtocolSupport, you can find the old builds below.

About this page

This page contains old, unsupported versions of ProtocolSupport.

If you really need them, you can download them here. However, in doing so, you are agreeing that:

  • You will receive no support if you decide to use these builds.
  • Any problems you find in these builds will not be fixed.
  • Any issues you report for these builds will be closed.
  • Requesting support on Discord for these builds will result in a mute or kick.

If you decide to update to the current build of ProtocolSupport, we will once again provide you with support.

Additionally, we request that you do not share these builds with anyone directly. If you'd like to link these builds to another user, then feel free to link to this page instead. Do not rehost these builds.

Please answer the following questions to gain access to the downloads